Enable rules not working

Nov 7, 2012 at 6:43 PM

First of all, thanks for a GREAT tool!  Really works well.

I am having an issue with Enable Rules though, and I'm guessing it's because of my lack of familiarity with how they work.

I have a group of icons on the Opp form that outline the sales process.  I want all icons to be visible, but only one icon to be active based on the value in the Pipeline Phase (stepname) field.

I do the following:

  1. Go to the Enable Rules tab and press Add
  2. Select ValueRule
    • for the field, I type stepname (all lower case to match the name in CRM)
    • For the value, I type Discover (same case as stored in CRM)
  3. I save the ribbon and launch CRM

When I go into the opportunity record, the button is enabled for all records, regardless of value in the Pipeline Phase field.

Appreciate any thoughts you have about this.  Thanks!

Rick

Developer
Nov 12, 2012 at 11:51 PM

Hi, Rick.

If field value used in ValueRule is empty, when the rule will need Default option set to work correctly.
The reason is by design: if field is empty (= null), Ribbon cannot determine the value of the field and needs to know how this button should be rendered by default.
If you put false for Default option, the button will not be enabled for empty fields (and vise versa).

Could this be a reason for the behavior you are experiencing?

Marked as answer by EvgenijM on 4/26/2014 at 4:09 AM